PermissionError when authenticating with openeo version 0.14.1

I noticed a possible bug, I hope it’s okay for me to report this here.

I created a new conda environment with a fresh install of openeo (= version 0.14.1) and suddenly ran into an error when authenticating with

connection = openeo.connect(“”).authenticate_oidc()

The error:
PermissionError: File C:\Users\UserName\AppData\Roaming\openeo-python-client\refresh-tokens.json could be readable by others: mode 707 (expected: 600).

The environment I usually work with has openeo version 0.13.0. I’ve never encountered the error there. Indeed, downgrading to the older version in the new environment with

pip install openeo==0.13.0

worked to get rid of the error.

Kind regards,

Hi @margot.verhulst . Could you please try this solution for clearing the old token proposed by @stefaan.lippens here? Error: type object 'UDF' has no attribute 'from_file' - #8 by stefaan.lippens

Hi @michele.claus, that worked as well, so then a downgrade to 0.13.0 is not needed anymore. Also, no problems with authentication now in the environment that still has version 0.13.0.

Indeed, since version 0.14.0 the handling of refresh token files is tightened down on Windows.

I’m not sure I understand correctly: did you remove the refresh token file and does version 0.14.1 work again for you? Or are you still on 0.13.0 everywhere?

Hi @stefaan.lippens,
I removed the refresh token as per the instructions. I still have my old environment with 0.13.0 and I have a new one with 0.14.1. Authentication currently works in both environments (I work in PyCharm with conda environments).
Additionally, I just ran a small script in both environments and everything seems to be working.

I just assume if I run into this error again, I would have to remove the refresh token again, is that correct?

great, thanks for that clarification

if you switch back and forth between 0.13 and 0.14 environments, you indeed might encounter this issue again (a refresh token file initialized with 0.13 will be rejected by 0.14, for example). But indeed, just removing the refresh token file should fix that

1 Like