Batch Job Vito Error

When I tried to send a batch job, I have not received any successful jobs yet. I have tried multiple different jobs but it seems it does not work for me for an unknown reason

After a few minutes I get this error:
JobFailedException: Batch job vito-4564c37f-209c-4296-9bc3-a782071c79bf didn't finish properly. Status: error (after 0:07:01).

Here is the link to eolab: JupyterHub

This is an overview of progress on thesent batch job on EO jupyterhub:

Can we get more detailed description of this error?

yes, the job object has a ‘logs’ method that will retrieve more logging if available.
This is also shown here:

The very latest version of the python client also tries to do that automatically. I believe that the Jupyter notebook environment does not automatically update the client after you accessed it once.
You could try upgrading the client yourself using pip:
pip install --user openeo --upgrade

I found the logs of your job, and these are the interesting parts:

"process_id": "filter_bbox",
   "arguments": {
    "extent": {
     "west": 16.138916,
     "east": 16.524124,
     "north": 48.320647,
     "south": 48.1386,
     "crs": 4326

  File "/opt/spark3_2_0/python/lib/", line 1309, in __call__
  File "/opt/spark3_2_0/python/lib/", line 330, in get_return_value
py4j.protocol.Py4JError: An error occurred while calling o814.setGlobalExtent. Trace:
py4j.Py4JException: Method setGlobalExtent([class java.lang.Double, class java.lang.Double, class java.lang.Double, class java.lang.Double, class java.lang.Integer]) does not exist

You appear to be passing the crs as an integer EPSG code 4326, while the VITO backend at the moment expects a string like "epsg:4326". This is a known limitation of the VITO backend. I would suggest to pass "epsg:4326" or to omit that field all together, because EPSG 4326 is the default

FYI: I created bug report here as well: