ESA World Cereal

Cant download esa maize maps anymore. Is there an issue currently with this service ?

I used to follow same approach on july by using the wizard to create patch job and its was running smoothly with no errors.
Now as soon as job is created, a time our error shows up.
I tried several times with different coordinates and time spans and same error.
The error shows up as soon as job start.
I follow same procedure described here:

here is the error:
Network Error

  • Data:
    • Config:
      • Transitional:
        • Silent JSONParsing: :heavy_check_mark:
        • Forced JSONParsing: :heavy_check_mark:
        • Clarify Timeout Error: :x:
      • Adapter: JavaScript Function
      • Transform Request:
        1. JavaScript Function
      • Transform Response:
        1. JavaScript Function
      • Timeout: 0
      • Xsrf Cookie Name: XSRF-TOKEN
      • Xsrf Header Name: X-XSRF-TOKEN
      • Max Content Length: -1
      • Max Body Length: -1
      • Validate Status: JavaScript Function
      • Headers:
        • Accept: application/json, text/plain, /
        • Content Type: application/json
        • Authorization:
      • Method: post
      • Response Type: json
      • Url: /jobs/j-23102797a48d46d0838487f989700110/results
      • Data: {}
      • Base URL:
    • Request: Empty
    • Response:
    • Is Axios Error: :heavy_check_mark:
    • To JSON: JavaScript Function

this works at my end:

import openeo

con = openeo.connect("")

cube = con.load_collection(
    temporal_extent=["2020-09-01", "2021-12-20"],
    spatial_extent={"west": 3, "south": 51, "east": 3.1, "north": 51.1},

gives me a netCDF with a single observation at 2021-11-06 FYI

i want the output in geotiff format not netcdf so how to tweak that please?"maize.tiff")

thank you i will give it a try now hope it works !

Note: I’d recommend to remove the part Authorization: Bearer oidc/egi/... from your original post because this exposes your credentials and allows other users to impersonate you

sure thanks for the tip
here is my code start:

Connect to the back-end

connection = openeo.connect(“”)
print(“Authenticate with OIDC authentication”)

maize = connection.load_collection(collection_id = “ESA_WORLDCEREAL_MAIZE”, spatial_extent = {“west”: 8.048519233845084, “east”: 12.824160818748563, “south”: 54.59015620868928, “north”: 57.0204773836667}, temporal_extent = [“2020-09-12T00:00:00Z”, “2021-12-20T00:00:00Z”],bands=[“classification”])

i get an openEoApiError

OpenEoApiError: [403] PermissionsInsufficient: Proper enrollment in openEO Platform virtual organization is required. (ref: r-c6e2646044c14a76964f349a21a895db)

even if i am enrolled

can you share your user id?

e.g the output of


one moment i am on it

‘Nabta Playa’

That error happened with your other nabtaplaya account, are you sure it is enrolled too?

I believe was kind of getting same errors in both accounts.
Even if i reset and reentolled the origianl one following your colleague advice and it renewd my activition status but also with no succuess.

this is the answer iwth nabtaplaya account:
{“sub”:“Nabta Playa”,“voperson_verified_email”:[“”],“email_verified”:true,“eduperson_assurance”:[“",“”],“email”:"”}

I use this code with nabtaplaya:
import openeo
from openeo.processes import process
import requests
con = openeo.connect(“”)
cube = con.load_collection(
temporal_extent=[“2020-09-01”, “2021-12-20”],
spatial_extent={“west”: 3, “south”: 51, “east”: 3.1, “north”: 51.1},

and i get following error:

OpenEoApiError: [401] unknown: Unauthorized

That’s a curious result (I’ve never seen a custom sub value like that).

What option do you pick for this account at this phase of the authentication flow:

Do you have the Python full stack trace or error message, possibly including a request references like r-abcd1234234242342342543543343463?

I always checkin with google

I am using jupiter lap so not sure.
May i ask how it come that i created two new accounts and none of them works?

Is there a problem on the platform or is it more my accounts ?