Import Error: no module named 'fiona'

Dear all,

I have just cloned the Basic Training repository now, and I am in the openEO_NDVItimeseriesAnalysis_solution.ipynb notebook. While running the cell to load the polygons with the crop parcels, I get an import error for the ‘fiona’ package.

Thanks for your help!


"ImportError: the ‘read_file’ function requires the ‘fiona’ package, but it is not installed or does not import correctly.
Importing fiona resulted in: No module named ‘fiona’ "

Hi Amalia, can you try to run in a cell: !pip install geopandas
This should install geopandas with all its dependencies (like fiona).
After that, please restart the kernel and try again.

Hi Michele,

I am not having much success.

I run in a cell !pip install geopandas

Then I restart the Kernel by going to File > Hub Control Panel > Stop My Server, and then I Restart the server.
I go again to the Notebook, run the code, and get the same error.

Hi Michele,
We solved it by executing “pip install fiona” from the Terminal.


1 Like