Validation of process failed


I wanted to develop a new function for the R client to retrieve sample data for local prototyping. Therefore I created a really simple example that just loads the collection and saves it:

<other R code>
coll = list_collections()
p = processes()
f = list_file_formats()

data = p$load_collection(id = coll$SENTINEL2_L2A,
                         spatial_extent = list(west=6.75,south=51.85,east=7.25,north=52.15),
                         temporal_extent = list("2021-03-15","2021-04-02"))

res = p$save_result(data = data, format = f$output$GTiff)

Yesterday I had some issues to get the job starting, but it worked today. However, as I had troubles to start it yesterday, I ran the server-side process validation with that process and got the following error:

[ProcessUnsupported] Process with identifier 'load_collection' is not available in namespace 'backend'.

In case you want to reproduce the error, here is the JSON representation:

  "process_graph": {
    "load_collection_NSEFP2807V": {
      "process_id": "load_collection",
      "arguments": {
        "id": "SENTINEL2_L2A",
        "spatial_extent": {
          "west": 6.75,
          "south": 51.85,
          "east": 7.25,
          "north": 52.15
        "temporal_extent": [
        "bands": [
    "save_result_WTKOO1978Q": {
      "process_id": "save_result",
      "arguments": {
        "data": {
          "from_node": "load_collection_NSEFP2807V"
        "format": "GTiff",
        "options": {}
      "result": true
  "parameters": [],
  "returns": {
    "schema": {
      "type": "boolean"

Looks like a bug indeed, need to look into it. I in fact used the validation myself recently with a more complex process graph, which did seem to work.
So this graph gets sent to the validation endpoint right?

Yes, I have sent it to the validation endpoint. I haven’t checked it further, but theoretically the empty parameters or the returns might cause trouble somehow.

confirmed, the aggregator at does not properly support the /validation endpoint

I will see if I can find a quick fix for that

unfortunately no quick fix,
it will take a bit more effort, so I created github ticket for it: `/validation` support · Issue #42 · Open-EO/openeo-aggregator · GitHub